Welcome to the Quilting Board!

Already a member? Login above
loginabove
OR
To post questions, help other quilters and reduce advertising (like the one on your left), join our quilting community. It's free!

Results 1 to 2 of 2

Thread: Janome 6600 accufeed spring

  1. #1
    Junior Member luvrazz's Avatar
    Join Date
    Jul 2008
    Location
    san diego, ca
    Posts
    117
    I have a Janome 6600 and a year or so ago the spring that holds up the accufeed when not in use got disconnected, repairman fixed it in 2 seconds... It happened again and I hate to take it in again if it is something I can fix... Anybody else ever have this problem?

  2. #2
    k3n
    k3n is offline
    Power Poster k3n's Avatar
    Join Date
    Feb 2009
    Location
    Somerset, England
    Posts
    10,714
    Blog Entries
    1
    Firstly is it still under warranty? If so I wouldn't mess with it. I just took the screw out of the end of the head of mine and peeped inside - I see the spring you refer to, has it come off at the top where it joins the take up bar or at the bottom, where it attaches to the Acufeed thingy? If it's the top, it looks fairly accessible so I'd try myself. As long as it wasn't under warranty. One thing though - there are wires in there - switch off and unplug first, don't electrocute yourself!

    PS If it's happened twice, perhaps mention it next service as there may be another reason this is happening - has the spring got stretched for eg?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO ©2011, Crawlability, Inc.