Welcome to the Quilting Board!

Already a member? Login above
loginabove
OR
To post questions, help other quilters and reduce advertising (like the one on your left), join our quilting community. It's free!

Results 1 to 4 of 4

Thread: Featherweight won't stop

  1. #1
    Senior Member pinkCastleDH's Avatar
    Join Date
    Sep 2011
    Location
    Wisconsin
    Posts
    457

    Featherweight won't stop

    Finally getting around to working on some of the machines and this is the first one that is giving me fits. Plug it in and it goes, full speed. The foot controller doesn't affect anything. I know I've read about this problem before on the forum but I wasn't finding it and the sewing machine place closes early today if I need parts so I thought a direct appeal rather than further searching was in order. Anyone have any ideas? The wiring looks good but I haven't pulled the foot control apart to see what's inside of it yet.

  2. #2
    Super Member J Miller's Avatar
    Join Date
    Feb 2012
    Location
    Central IL
    Posts
    6,603
    Flip the machine over and pull the bottom off. Look for capacitors. If you find any, remove them. There could be two in the machine and could be one in the foot controller too. They were used to reduce interference on televisions back in the old black and white days.

    http://thefeatherweight221factory.com/page10.php

    Follow the big red arrow to the lower left and click on "the machine runs on it's own".

    Joe

  3. #3
    Senior Member pinkCastleDH's Avatar
    Join Date
    Sep 2011
    Location
    Wisconsin
    Posts
    457
    Joe, thanks. In this case that wasn't it, though. At some point someone was using the cord to pull the plug block out of the machine rather than the handy-dandy indents that were put there for that purpose. Pulled the plug block apart and it was immediately obvious that I had a short. Fixed that and it works great. Yay!

  4. #4
    Super Member J Miller's Avatar
    Join Date
    Feb 2012
    Location
    Central IL
    Posts
    6,603
    Glad you got it fixed. And that it was an easy fix. At least it didn't ark weld the contacts together like my 15-91 did when I tried to make it go the first time. Boy that get my attention!!!!!!!!!!!!

    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO ©2011, Crawlability, Inc.