Welcome to the Quilting Board!

Already a member? Login above
loginabove
OR
To post questions, help other quilters and reduce advertising (like the one on your left), join our quilting community. It's free!

Results 1 to 8 of 8

Thread: HELP! Thread nest, and the usual solutions don't work!

  1. #1
    Super Member JoanneS's Avatar
    Join Date
    Mar 2008
    Location
    AZ and CT
    Posts
    4,888
    Blog Entries
    1

    HELP! Thread nest, and the usual solutions don't work!

    Total frustration. I'm quilting with my new Pfaff Creative Sensation, and I keep getting a nest of thread underneath. I'm using a decorative stitch that I designed, using the design feature on the machine. I've tried all the usual things: rethread, clean out lint, make sure the bobbin is in correctly, change tension - even though this miracle machine is SUPPOSED to set tension correctly. I'm using Superior Rainbow thread on top. I WAS using Superior Bottom Line in the bobbin. Then I changed to Sulky Rayon 40 on the bottom. Didn't help. I'd rather not use the Rainbow on the bottom.

    I think Dr. Bob of Signature Thread has a Thread Tutorial somewhere in You Tube, but I don't know how to search on You Tube.

    I suspect someone on the board can help.

  2. #2

  3. #3
    Super Member JoanneS's Avatar
    Join Date
    Mar 2008
    Location
    AZ and CT
    Posts
    4,888
    Blog Entries
    1

  4. #4
    Junior Member NewbieToQuilting's Avatar
    Join Date
    Sep 2012
    Location
    Arkansas
    Posts
    112
    Quote Originally Posted by JoanneS View Post
    Thank you - that's exactly what I was looking for!
    *****************
    how did you fix the problem? The video is no longer available and my new Pfaff is doing the same thing!

  5. #5
    Junior Member coffeebreak's Avatar
    Join Date
    Apr 2012
    Posts
    139
    My Singer will do that when I FMQ meandering from time to time. Thing is...on the top it looks perfect stitch. The machien makes no sounds that anything is wrong..works just fine..nothing out of the ordinary, nothing to say something is wrong. Then when I finish and turn over to cut thread ends....lord have mercy.. the whole area I did is nothing but the thread nests! I can fix it if I adjust the thread tension but still...why would the machine not say something is wrong? The thing bleeps loudly if you tap the foot peddle and the pressure foot is not down. It bleeps loudly if the needle is not threaded. It beeps when turned on or off. But.. when this tension is like this.. not a sound AND when the bobbin thread goes out...it doesnt' beep. I have sewed all over before I noticed the bobbin thread was gone! I mean.. we look at what it is doing as it goes through and before, but I dont' know about you but I dont look at it after it passes through the needle/pressure foot... until I am done with the seam or technique!

  6. #6
    Senior Member
    Join Date
    Mar 2011
    Posts
    415
    Blog Entries
    2
    USUALLY, and I do mean usually, when you have a bobbin thread problem, The issue is somewhere in the upper thread system. I had been sewing for 12 years before someone shared this info with me.

  7. #7
    Super Member irishrose's Avatar
    Join Date
    Nov 2010
    Location
    Cadillac, MI
    Posts
    6,583
    Blog Entries
    19
    Newbie, it opened for me.
    http://www.youtube.com/watch?v=a1qJR8qoCyE

  8. #8
    Junior Member NewbieToQuilting's Avatar
    Join Date
    Sep 2012
    Location
    Arkansas
    Posts
    112
    Quote Originally Posted by irishrose View Post
    ******************
    Got it, thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO ©2011, Crawlability, Inc.