Singer motor help

Old 03-19-2022, 11:05 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Apr 2020
Location: South of St Louis
Posts: 822
Default Singer motor help

I am trying to clean up this motor to attach to a 99, and am having problems removing the grease tubes to get to the wicks. I've been able to work them loose in the past the few times I've removed them. I think this is an older motor because these tubes are much more substantial than others I've removed.

Any tips, tricks, suggestions?
Attached Thumbnails 20220319_120801.jpg  
JoeJr is offline  
Old 03-21-2022, 02:39 PM
  #2  
Senior Member
Thread Starter
 
Join Date: Apr 2020
Location: South of St Louis
Posts: 822
Default

For future reference
1. I shot a small amount of WD40 at the base of each tube
2. Applied heat via the heat gun
3. Tapped each tube using a hammer and the large end of punch while clamped in the bench vise

And then pulled them straight out with the pliers. Next is cleaning (including replacing the black stalks which are the old wicks), reassembly, and testing.
Attached Thumbnails 20220321_173108.jpg  
JoeJr is offline  
Old 03-21-2022, 06:27 PM
  #3  
Super Member
 
OurWorkbench's Avatar
 
Join Date: Mar 2015
Location: Denver, CO
Posts: 4,290
Default

Thank you, for letting us know what worked.


Janey - Neat people never make the exciting discoveries I do.
OurWorkbench is offline  
Old 03-23-2022, 12:28 AM
  #4  
Junior Member
 
Join Date: Jan 2021
Posts: 145
Default

I had no idea these things could be removed. I never even tried. In the past I just fished the old wicks out from the inside of the motor housing and replaced them the same way after cleaning.
1.41 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


FREE Quilting Newsletter