Welcome to the Quilting Board!

Already a member? Login above
loginabove
OR
To post questions, help other quilters and reduce advertising (like the one on your left), join our quilting community. It's free!

Page 3 of 3 FirstFirst ... 2 3
Results 21 to 22 of 22

Thread: Janome 7700 Problems-Suggestions?

  1. #21
    Junior Member quiltnchik's Avatar
    Join Date
    Oct 2010
    Location
    In my sewing studio - where else?
    Posts
    236
    Quote Originally Posted by krabadan
    Did you get the new O2 foot with it? If not, register the machine and Janome will send it. The 1/4" foot was redesigned to accommodate thick seems. I personally haven't had that problem with mine.
    I don't have the 7700, but have had this problem with my 6600P since I bought it. I'm not sure why they didn't come out with this "fix" for those of us with the 6600P, but I know the O2 foot will also work on the 6600 and have contacted them asking for one.

  2. #22
    Senior Member Jamiestitcher62's Avatar
    Join Date
    Jul 2010
    Location
    Connecticut
    Posts
    726
    I have been concerned with this when I owned the 6600. I traded up to the 7700 and the same thing happened. The Accufeed does have a 1/4" foot. You buy it separately, however you can't use the single stitch hole because the needle position is at 5.5 on the Accufeed 1/4 foot.

    I just received my new 7700 regular 1/4" foot. They changed the design of the bottom of the foot.

    I think the Accufeed system is part of the problem because of the different style of feed dog to accommodate the Accufeed feet. It just causes all kinds of other issues when not using the Accufeed feet.

Page 3 of 3 FirstFirst ... 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO ©2011, Crawlability, Inc.