Welcome to the Quilting Board!

Already a member? Login above
loginabove
OR
To post questions, help other quilters and reduce advertising (like the one on your left), join our quilting community. It's free!

Results 1 to 6 of 6

Thread: Juki 2010q bobbin wind problem

  1. #1
    Senior Member rushdoggie's Avatar
    Join Date
    Feb 2011
    Location
    Vancouver, WA
    Posts
    994

    Juki 2010q bobbin wind problem

    Hello!

    I have a brand new Juki 2010Q. I have been playing with her a little, to get used to her. I wound one bobbin and inserted it no problem, threaded the machine, and ran it for a while. When the bobbin ran out, I tried to fill it again but managed to have the thread spool backwards and the thread caught in the notch in the spool. As I pressed the foot pedal it stopped and jammed.

    I realized what happened, fixed the spool, rethreaded the bobbin winder but now it won't wind at all, nothing happens when I have the bobbin level pushed over and press the foot pedal. If I move the bobbin lever out of the way pressing the foot pedal makes the needle go up and down, its only the bobbin winding that doesn't work.

    Help?
    Beth

  2. #2
    Junior Member
    Join Date
    Nov 2011
    Location
    Central,CALIF.
    Posts
    243
    Perhaps it has nothing to do with your new Juki, but my TL98E little bobbin slot has to be pushed into the right spot on the winder... or it does not wind at all...I really love this machine, and want the 2010Q someday down the road..

  3. #3
    Senior Member rushdoggie's Avatar
    Join Date
    Feb 2011
    Location
    Vancouver, WA
    Posts
    994
    OMG, I am such a moron. The notch wasn't lined up correctly!! It works perfectly!

    Thank you!
    Beth

  4. #4
    Junior Member
    Join Date
    Nov 2011
    Location
    Central,CALIF.
    Posts
    243
    You're welcome, and you are NOT a moron...

  5. #5
    Senior Member rushdoggie's Avatar
    Join Date
    Feb 2011
    Location
    Vancouver, WA
    Posts
    994
    oh I felt like I had broken my new machine, and I was so stressed out, and all I had to do was readjust so the notch was lined up...I sure felt like one!
    Beth

  6. #6
    Senior Member asimplelife's Avatar
    Join Date
    Oct 2012
    Location
    Northern Minnesota
    Posts
    486
    I just got this machine too... Unfortunately my power cord and bobbin case were missing so playtime has to wait until Mondays mail. I've read so many great things about it and am excited to have a thread cutter and knee lift. Patience...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO ©2011, Crawlability, Inc.