Go Back  Quiltingboard Forums > Main
My Viking's back!!!  I had to share! >

My Viking's back!!! I had to share!

My Viking's back!!! I had to share!

Old 04-02-2012, 05:05 AM
  #1  
Senior Member
Thread Starter
 
lenette's Avatar
 
Join Date: Feb 2011
Location: Lansing, Michigan
Posts: 504
Default My Viking's back!!! I had to share!

Took it in for repairs a week ago, and picked it up Saturday. Yay! I had it cleaned and adjusted. It had started making nests underneath. Can't imagine how it got out of wack They recentered the needle, and checked the wires. But, best of all, they didn't have to replace the computer board!!! Whatever adjustments they did fixed it and it now displays what feet I need for each stitch again!! I feel pretty giddy about it!
lenette is offline  
Old 04-02-2012, 05:52 AM
  #2  
Power Poster
 
Join Date: Jan 2011
Location: Upland CA
Posts: 18,376
Default

Congrats!!!!!!!!!!!
mighty is offline  
Old 04-02-2012, 05:58 AM
  #3  
Super Member
 
Join Date: Aug 2010
Location: Piedmont Virginia in the Foothills of the Blue Ridge Mtns.
Posts: 8,545
Default

Giddy...I'm sure you are, no big $$$ to fork out!! Yay for you! Makes for a wonderful day, enjoy.

Jan in VA
Jan in VA is offline  
Old 04-02-2012, 06:37 AM
  #4  
Super Member
 
Join Date: Jul 2011
Location: N. Florida
Posts: 4,569
Default

Good news. Have fun sewing with her.
annthreecats is offline  
Old 04-02-2012, 07:08 AM
  #5  
Super Member
 
Join Date: Nov 2010
Location: MS
Posts: 2,624
Default

Yay!! So glad she is well again!
Nanamoms is offline  
Old 04-02-2012, 11:58 AM
  #6  
Super Member
 
Join Date: Jan 2011
Location: Minnesota
Posts: 4,144
Default

Just got my Viking back from the shop, too. She runs a lot quieter now. I thought electronic machines didn't need cleaning like the old ones. She purrrrrs like a kitten now!
Sandra in Minnesota is offline  
Old 04-02-2012, 03:02 PM
  #7  
Senior Member
 
kacklebird's Avatar
 
Join Date: Dec 2010
Posts: 799
Default

I love my Viking
kacklebird is offline  
Old 04-02-2012, 03:04 PM
  #8  
Junior Member
 
Join Date: Jan 2011
Location: Charleston, WV
Posts: 258
Default

I sent my Viking in at Christmas and hasn't gotten it back yet. There was nothing wrong with it, just the cord!
jaly3162 is offline  
Old 04-02-2012, 06:47 PM
  #9  
Senior Member
Thread Starter
 
lenette's Avatar
 
Join Date: Feb 2011
Location: Lansing, Michigan
Posts: 504
Default

Have you called and checked on it? That seems like way too long. Maybe they forgot about it.
lenette is offline  
Old 04-02-2012, 06:49 PM
  #10  
Senior Member
 
Jennie and Me's Avatar
 
Join Date: Jul 2011
Location: N.W. Missouri
Posts: 858
Default

Originally Posted by jaly3162 View Post
I sent my Viking in at Christmas and hasn't gotten it back yet. There was nothing wrong with it, just the cord!
Ummmm, I think that I'd be calling about it...that's a long time for it to be away from home!!
I love my Viking and hope it stays with me forever.
Jennie and Me is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


FREE Quilting Newsletter


SEO by vBSEO ©2011, Crawlability, Inc.