Stiff motor singer 99k

Old 02-15-2021, 03:09 AM
  #1  
Member
Thread Starter
 
Join Date: Feb 2021
Posts: 2
Default Stiff motor singer 99k

I recently bought a singer, brilliant tool! But I was using it last night and it went stiff at the motor, it works fine with just the crank but when I reattach the belt to the motor it doesn't move. I don't know what type of oil or even where to oil it if that is the answer??

Has anyone ever had this problem? Thanks in advance for any help
Binnes1985 is offline  
Old 02-15-2021, 08:02 AM
  #2  
Super Member
 
OurWorkbench's Avatar
 
Join Date: Mar 2015
Location: Denver, CO
Posts: 2,819
Default

When you say "it works fine with just the crank" are you referring to it sewing smoothly with the hand wheel? If you remove the belt and run the motor, does the pulley spin? Is it possible the belt is too tight or does the belt slip?

We like pictures. In order to post pictures on Quilting Board, you will probably need to reduce or compress the picture to a file size that is smaller than 2MB. How to post images can be found at https://www.quiltingboard.com/attach...020-01-17-.pdf
Don't forget to scroll over to the far right to find and click on the "Upload" button.

I have found that only the big red "Reply" button or "Quote" work to give me the paper clip icon to work for adding pictures.
https://www.quiltingboard.com/attach...p-location.jpg

Some additional info regarding reducing images at post #4 and images for the scroll and upload button can be found at #5 of https://www.quiltingboard.com/main-f...d-t312607.html

Janey - Neat people never make the exciting discoveries I do.
OurWorkbench is offline  
Old 02-15-2021, 09:16 AM
  #3  
Member
Thread Starter
 
Join Date: Feb 2021
Posts: 2
Default

Originally Posted by OurWorkbench View Post
When you say "it works fine with just the crank" are you referring to it sewing smoothly with the hand wheel? If you remove the belt and run the motor, does the pulley spin? Is it possible the belt is too tight or does the belt slip?

We like pictures. In order to post pictures on Quilting Board, you will probably need to reduce or compress the picture to a file size that is smaller than 2MB. How to post images can be found at https://www.quiltingboard.com/attach...020-01-17-.pdf
Don't forget to scroll over to the far right to find and click on the "Upload" button.

I have found that only the big red "Reply" button or "Quote" work to give me the paper clip icon to work for adding pictures.
https://www.quiltingboard.com/attach...p-location.jpg

Some additional info regarding reducing images at post #4 and images for the scroll and upload button can be found at #5 of https://www.quiltingboard.com/main-f...d-t312607.html

Janey - Neat people never make the exciting discoveries I do.

Thank you very much for your reply

Yes the wheel works perfectly by turning the wheel by hand and stitches perfectly also doing so.

When I take the belt off the small black plastic "wheel" attached to the motor is now very very stiff
Binnes1985 is offline  
Old 02-15-2021, 02:44 PM
  #4  
Senior Member
 
Join Date: Apr 2020
Location: South of St Louis
Posts: 349
Default

Welcome to the Board!

Here's a recent thread about working on motors, I'm sure there are others as well:

https://www.quiltingboard.com/vintag...a-t314081.html
JoeJr is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


FREE Quilting Newsletter


SEO by vBSEO ©2011, Crawlability, Inc.